<!DOCTYPE html>
<html lang="en-US" >
<head>

<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="https://respect-mag.com/xmlrpc.php" />

 
<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/5308475/728x90_atf_ros', [728, 90], 'div-gpt-ad-1562897092043-0').addService(googletag.pubads());
    googletag.defineSlot('/5308475/300x250_atf_ros', [300, 250], 'div-gpt-ad-1562897488552-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-143292939-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-143292939-1');
</script>
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-30645438-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-30645438-1');
</script>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-6663449431820094",
          enable_page_level_ads: true
     });
</script>
<title>Get Familiar With The Haitian Sensation, Mig Arogan | RESPECT.</title>

<!-- Open Graph Meta Tags generated by MashShare 3.7.2 - https://mashshare.net -->
<meta property="og:type" content="article" /> 
<meta property="og:title" content="Get Familiar With The Haitian Sensation, Mig Arogan" />
<meta property="og:description" content="Haiti is known for becoming an influential movement in politics, pop and hip hop culture. Just look at the roster. Future, Ace Hood and legendary emcee, Wyclef Jean. A Grammy-award winner and platinum emcee, Wyclef" />
<meta property="og:image" content="https://respect-mag.com/wp-content/uploads/2020/03/F96C5E99-E0EE-4309-847B-D2B0A735ED4A.jpeg" />
<meta property="og:url" content="https://respect-mag.com/2020/03/get-familiar-with-the-haitian-sensation-mig-arogan/" />
<meta property="og:site_name" content="RESPECT." />
<meta property="article:publisher" content="https://www.facebook.com/respectmag" />
<meta property="article:published_time" content="2020-03-12T14:42:20-04:00" />
<meta property="article:modified_time" content="2020-03-12T19:29:17-04:00" />
<meta property="og:updated_time" content="2020-03-12T19:29:17-04:00" />
<!-- Open Graph Meta Tags generated by MashShare 3.7.2 - https://www.mashshare.net -->
<!-- Twitter Card generated by MashShare 3.7.2 - https://www.mashshare.net -->
<meta property="og:image:width" content="828" />
<meta property="og:image:height" content="828" />
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:title" content="Get Familiar With The Haitian Sensation, Mig Arogan">
<meta name="twitter:description" content="Haiti is known for becoming an influential movement in politics, pop and hip hop culture. Just look at the roster. Future, Ace Hood and legendary emcee, Wyclef Jean. A Grammy-award winner and platinum emcee, Wyclef">
<meta name="twitter:image" content="https://respect-mag.com/wp-content/uploads/2020/03/F96C5E99-E0EE-4309-847B-D2B0A735ED4A.jpeg">
<meta name="twitter:site" content="@respectmag">
<!-- Twitter Card generated by MashShare 3.7.2 - https://www.mashshare.net -->


<!-- This site is optimized with the Yoast SEO plugin v13.2 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://respect-mag.com/2020/03/get-familiar-with-the-haitian-sensation-mig-arogan/" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://respect-mag.com/#organization","name":"RESPECT. Magazine","url":"https://respect-mag.com/","sameAs":["https://www.facebook.com/respectmag/","https://www.instagram.com/respectthemag/","https://www.linkedin.com/company/respect.-magazine/","https://www.youtube.com/RESPECTMagazine","https://twitter.com/respectmag"],"logo":{"@type":"ImageObject","@id":"https://respect-mag.com/#logo","inLanguage":"en-US","url":"https://i1.wp.com/respect-mag.com/wp-content/uploads/2018/09/respectlogo.jpg?fit=459%2C100&ssl=1","width":459,"height":100,"caption":"RESPECT. Magazine"},"image":{"@id":"https://respect-mag.com/#logo"}},{"@type":"WebSite","@id":"https://respect-mag.com/#website","url":"https://respect-mag.com/","name":"RESPECT.","inLanguage":"en-US","description":"The Photo Journal of Hip-Hop Culture","publisher":{"@id":"https://respect-mag.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://respect-mag.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://respect-mag.com/2020/03/get-familiar-with-the-haitian-sensation-mig-arogan/#primaryimage","inLanguage":"en-US","url":"https://i2.wp.com/respect-mag.com/wp-content/uploads/2020/03/F96C5E99-E0EE-4309-847B-D2B0A735ED4A.jpeg?fit=828%2C828&ssl=1","width":828,"height":828},{"@type":"WebPage","@id":"https://respect-mag.com/2020/03/get-familiar-with-the-haitian-sensation-mig-arogan/#webpage","url":"https://respect-mag.com/2020/03/get-familiar-with-the-haitian-sensation-mig-arogan/","name":"Get Familiar With The Haitian Sensation, Mig Arogan | RESPECT.","isPartOf":{"@id":"https://respect-mag.com/#website"},"inLanguage":"en-US","primaryImageOfPage":{"@id":"https://respect-mag.com/2020/03/get-familiar-with-the-haitian-sensation-mig-arogan/#primaryimage"},"datePublished":"2020-03-12T18:42:20+00:00","dateModified":"2020-03-12T23:29:17+00:00"},{"@type":"Article","@id":"https://respect-mag.com/2020/03/get-familiar-with-the-haitian-sensation-mig-arogan/#article","isPartOf":{"@id":"https://respect-mag.com/2020/03/get-familiar-with-the-haitian-sensation-mig-arogan/#webpage"},"author":{"@id":"https://respect-mag.com/#/schema/person/155c09ee357a7a51d0c25e03d37483e2"},"headline":"Get Familiar With The Haitian Sensation, Mig Arogan","datePublished":"2020-03-12T18:42:20+00:00","dateModified":"2020-03-12T23:29:17+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://respect-mag.com/2020/03/get-familiar-with-the-haitian-sensation-mig-arogan/#webpage"},"publisher":{"@id":"https://respect-mag.com/#organization"},"image":{"@id":"https://respect-mag.com/2020/03/get-familiar-with-the-haitian-sensation-mig-arogan/#primaryimage"},"keywords":"Mig Arogan","articleSection":"Music","inLanguage":"en-US"},{"@type":["Person"],"@id":"https://respect-mag.com/#/schema/person/155c09ee357a7a51d0c25e03d37483e2","name":"Omari White","image":{"@type":"ImageObject","@id":"https://respect-mag.com/#authorlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/c4e12307790d9e7191af7b79d84679ef?s=96&d=mm&r=g","caption":"Omari White"},"sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="RESPECT. &raquo; Feed" href="https://respect-mag.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="RESPECT. &raquo; Comments Feed" href="https://respect-mag.com/comments/feed/" />
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1" /><meta name="format-detection" content="telephone=no"><meta property="og:type" content="article" /><meta property="og:image" content="https://i2.wp.com/respect-mag.com/wp-content/uploads/2020/03/F96C5E99-E0EE-4309-847B-D2B0A735ED4A.jpeg?resize=600%2C454&#038;ssl=1"/><meta property="og:title" content="Get Familiar With The Haitian Sensation, Mig Arogan"/><meta property="og:url" content="https://respect-mag.com/2020/03/get-familiar-with-the-haitian-sensation-mig-arogan/"/><meta property="og:description" content=""/><link rel="alternate" type="application/rss+xml" title="RESPECT. &raquo; Get Familiar With The Haitian Sensation, Mig Arogan Comments Feed" href="https://respect-mag.com/2020/03/get-familiar-with-the-haitian-sensation-mig-arogan/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/respect-mag.com\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.3.2/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mashsb-styles-css'  href='https://respect-mag.com/wp-content/plugins/mashsharer/assets/css/mashsb.min.css' type='text/css' media='all' />
<style id='mashsb-styles-inline-css' type='text/css'>
.mashsb-count {color:#cccccc;}@media only screen and (min-width:568px){.mashsb-buttons a {min-width: 177px;}}
</style>
<link rel='stylesheet' id='grandmagazine-reset-css-css'  href='https://respect-mag.com/wp-content/themes/RESPECT2.0/css/reset.css' type='text/css' media='all' />
<link rel='stylesheet' id='grandmagazine-wordpress-css-css'  href='https://respect-mag.com/wp-content/themes/RESPECT2.0/css/wordpress.css' type='text/css' media='all' />
<link rel='stylesheet' id='grandmagazine-animation-css'  href='https://respect-mag.com/wp-content/themes/RESPECT2.0/css/animation.css' type='text/css' media='all' />
<link rel='stylesheet' id='magnific-css'  href='https://respect-mag.com/wp-content/themes/RESPECT2.0/css/magnific-popup.css' type='text/css' media='all' />
<link rel='stylesheet' id='grandmagazine-jquery-ui-css-css'  href='https://respect-mag.com/wp-content/themes/RESPECT2.0/css/jqueryui/custom.css' type='text/css' media='all' />
<link rel='stylesheet' id='flexslider-css'  href='https://respect-mag.com/wp-content/themes/RESPECT2.0/js/flexslider/flexslider.css' type='text/css' media='all' />
<link rel='stylesheet' id='tooltipster-css'  href='https://respect-mag.com/wp-content/themes/RESPECT2.0/css/tooltipster.css' type='text/css' media='all' />
<link rel='stylesheet' id='grandmagazine-screen-css-css'  href='https://respect-mag.com/wp-content/themes/RESPECT2.0/css/screen.css' type='text/css' media='all' />
<link rel='stylesheet' id='grandmagazine-fonts-css'  href='https://fonts.googleapis.com/css?family=Roboto%3A300%2C400%2C500%2C600%2C700%7CPoppins%3A300%2C400%2C500%2C600%2C700&#038;subset=latin%2Ccyrillic-ext%2Cgreek-ext%2Ccyrillic' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css'  href='https://respect-mag.com/wp-content/themes/RESPECT2.0/css/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='grandmagazine-script-custom-css-css'  href='https://respect-mag.com/wp-admin/admin-ajax.php?action=grandmagazine_script_custom_css' type='text/css' media='all' />
<link rel='stylesheet' id='grandmagazine-script-responsive-css-css'  href='https://respect-mag.com/wp-content/themes/RESPECT2.0/css/grid.css' type='text/css' media='all' />
<link rel='stylesheet' id='kirki_google_fonts-css'  href='https://fonts.googleapis.com/css?family=Roboto%3A700%2C500%2C500%2C100%2C100italic%2C300%2C300italic%2Cregular%2Citalic%2C500%2C500italic%2C700%2C700italic%2C900%2C900italic%7CPoppins%3A500%2C500%2C100%2C100italic%2C200%2C200italic%2C300%2C300italic%2Cregular%2Citalic%2C500%2C500italic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%2C900%2C900italic&#038;subset' type='text/css' media='all' />
<link rel='stylesheet' id='kirki-styles-global-css'  href='https://respect-mag.com/wp-content/themes/RESPECT2.0/modules/kirki/assets/css/kirki-styles.css' type='text/css' media='all' />
<style id='kirki-styles-global-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='social-logos-css'  href='https://c0.wp.com/p/jetpack/8.3/_inc/social-logos/social-logos.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/8.3/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.3/_inc/build/related-posts/related-posts.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mashsb = {"shares":"0","round_shares":"1","animate_shares":"0","dynamic_buttons":"0","share_url":"https:\/\/respect-mag.com\/2020\/03\/get-familiar-with-the-haitian-sensation-mig-arogan\/","title":"Get+Familiar+With+The+Haitian+Sensation%2C+Mig+Arogan","image":"https:\/\/respect-mag.com\/wp-content\/uploads\/2020\/03\/F96C5E99-E0EE-4309-847B-D2B0A735ED4A.jpeg","desc":"Haiti is known for becoming an influential movement in politics, pop and hip hop culture. Just look at the roster. Future, Ace Hood and legendary emcee, Wyclef Jean. A Grammy-award winner and platinum emcee, Wyclef \u2026","hashtag":"respectmag","subscribe":"content","subscribe_url":"","activestatus":"1","singular":"1","twitter_popup":"1","refresh":"0","nonce":"e1921150e9","postid":"238493","servertime":"1584055946","ajaxurl":"https:\/\/respect-mag.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://respect-mag.com/wp-content/plugins/mashsharer/assets/js/mashsb.min.js'></script>
<link rel='https://api.w.org/' href='https://respect-mag.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://respect-mag.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://respect-mag.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.3.2" />
<link rel='shortlink' href='https://wp.me/p3P27B-102F' />
<link rel="alternate" type="application/json+oembed" href="https://respect-mag.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Frespect-mag.com%2F2020%2F03%2Fget-familiar-with-the-haitian-sensation-mig-arogan%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://respect-mag.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Frespect-mag.com%2F2020%2F03%2Fget-familiar-with-the-haitian-sensation-mig-arogan%2F&#038;format=xml" />

<!--Plugin WP Toolbar Removal 2014.0816.0392 Active - Tag 74be16979710d4c4e7c6647856088456-->

<!--Site Optimized to Speedup Control Panel Minimize Memory Consumption with Disabled Toolbar-->


<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<link rel='dns-prefetch' href='//c0.wp.com'/>
<style type='text/css'>img#wpstats{display:none}</style>			<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		<link rel="icon" href="https://i2.wp.com/respect-mag.com/wp-content/uploads/2018/06/cropped-logologo.png?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i2.wp.com/respect-mag.com/wp-content/uploads/2018/06/cropped-logologo.png?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://i2.wp.com/respect-mag.com/wp-content/uploads/2018/06/cropped-logologo.png?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i2.wp.com/respect-mag.com/wp-content/uploads/2018/06/cropped-logologo.png?fit=270%2C270&#038;ssl=1" />
			<style type="text/css" id="wp-custom-css">
				.post_img.featured_content {
	display: none;
}

.post_info_date {
	color: #ff0000;
}

.post_info_date a {
	color: #ff0000;
}

iframe#fitvid1 {
	width: 100%;
	height: 500px;
}

#footer {
	color: #ffffff
}

@media screen and (max-width: 500px) { 
	.bigad1 { 
		display: none; 
	}  
}

@media screen and (max-width: 500px) { 
	.bigad2 { 
		display: none; 
	}  
}

@media screen and (min-width: 500px) { 
	.smallad { 
		display: none; 
	}  
}			</style>
		</head>

<body class="post-template-default single single-post postid-238493 single-format-standard">

		<input type="hidden" id="pp_enable_right_click" name="pp_enable_right_click" value="1"/>
	<input type="hidden" id="pp_enable_dragging" name="pp_enable_dragging" value="1"/>
	<input type="hidden" id="pp_image_path" name="pp_image_path" value="https://respect-mag.com/wp-content/themes/RESPECT2.0/images/"/>
	<input type="hidden" id="pp_homepage_url" name="pp_homepage_url" value="https://respect-mag.com/"/>
	<input type="hidden" id="pp_ajax_search" name="pp_ajax_search" value="1"/>
	<input type="hidden" id="pp_fixed_menu" name="pp_fixed_menu" value="1"/>
	<input type="hidden" id="tg_smart_fixed_menu" name="tg_smart_fixed_menu" value="1"/>
	<input type="hidden" id="pp_topbar" name="pp_topbar" value=""/>
	<input type="hidden" id="tg_blog_slider_layout" name="tg_blog_slider_layout" value=""/>
	<input type="hidden" id="pp_back" name="pp_back" value="Back"/>
	<input type="hidden" id="tg_sidebar_sticky" name="tg_sidebar_sticky" value="1"/>
	
		<input type="hidden" id="pp_footer_style" name="pp_footer_style" value="2"/>
	
	<!-- Begin mobile menu -->
	<div class="mobile_menu_wrapper">    	
	    <div class="menu-top-menu-container"><ul id="mobile_main_menu" class="mobile_main_nav"><li id="menu-item-26747" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26747"><a href="https://cover.respect-mag.com/digitalcover/">Digital Cover</a></li>
<li id="menu-item-27223" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-27223"><a href="https://respect-mag.com/category/art-2/">Art</a>
<ul class="sub-menu">
	<li id="menu-item-26758" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-26758"><a href="https://respect-mag.com/category/art-2/photography-art-2/">Photography</a></li>
</ul>
</li>
<li id="menu-item-162220" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-162220"><a href="https://respect-mag.com/category/editorial-opinion/">Editorial/Opinion</a>
<ul class="sub-menu">
	<li id="menu-item-162221" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-162221"><a href="https://respect-mag.com/category/editorial-opinion/features/">Features</a></li>
	<li id="menu-item-162222" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-162222"><a href="https://respect-mag.com/category/editorial-opinion/reviews/">Reviews</a></li>
</ul>
</li>
<li id="menu-item-162223" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-162223"><a href="https://respect-mag.com/category/events/">Events</a>
<ul class="sub-menu">
	<li id="menu-item-162224" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-162224"><a href="https://respect-mag.com/category/events/concerts-2/">Concerts</a></li>
</ul>
</li>
<li id="menu-item-162225" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-162225"><a href="https://respect-mag.com/category/interviews/">Interviews</a></li>
<li id="menu-item-26761" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-26761"><a href="#">Lifestyle</a>
<ul class="sub-menu">
	<li id="menu-item-26762" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-26762"><a href="https://respect-mag.com/category/lifestyle/literature/">Literature</a></li>
	<li id="menu-item-26764" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-26764"><a href="https://respect-mag.com/category/lifestyle/sports-2/">Sports</a></li>
	<li id="menu-item-26763" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-26763"><a href="https://respect-mag.com/category/lifestyle/technology/">Technology</a></li>
	<li id="menu-item-162226" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-162226"><a href="https://respect-mag.com/category/lifestyle/tv-movies/">TV/Movies</a></li>
</ul>
</li>
<li id="menu-item-162227" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-162227"><a href="https://respect-mag.com/category/music/new-music-2/">New Music</a>
<ul class="sub-menu">
	<li id="menu-item-162228" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-162228"><a href="https://respect-mag.com/category/music/new-music-2/albums-mixtapes/">Albums/Mixtapes</a></li>
</ul>
</li>
<li id="menu-item-162229" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-162229"><a href="https://respect-mag.com/category/news-2/">News</a></li>
<li id="menu-item-26945" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-26945"><a href="https://respect-mag.com/category/style/">Style</a>
<ul class="sub-menu">
	<li id="menu-item-26946" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-26946"><a href="https://respect-mag.com/category/style/fashion-2/">Fashion</a></li>
</ul>
</li>
<li id="menu-item-162230" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-162230"><a href="https://respect-mag.com/category/videos/">Videos</a></li>
</ul></div>		
		<!-- Begin side menu sidebar -->
		<div class="page_content_wrapper">
			<div class="sidebar_wrapper">
		        <div class="sidebar">
		        
		        	<div class="content">
		        
		        		<ul class="sidebar_widget">
		        		<li id="grand_magazine_custom_ads-4" class="widget Grand_Magazine_Custom_Ads"><a href="https://www.dragopublisher.com/product/this-is-los-angeles/" rel="noopener" target="_blank"><img src="https://respect-mag.com/wp-content/uploads/2019/07/350x250.gif" alt="" width="300" height="600" class="aligncenter size-full wp-image-221862" /></a></li>
		        		</ul>
		        	
		        	</div>
		    
		        </div>
			</div>
		</div>
		<!-- End side menu sidebar -->
	</div>
	<!-- End mobile menu -->

	<!-- Begin template wrapper -->
		<div id="wrapper" class="menu_transparent">
	
	

<div class="header_style_wrapper">
<!-- End top bar -->

<div class="top_bar">
	<div class="standard_wrapper">
		<!-- Begin logo -->
		<div id="logo_wrapper">
		
				<div id="logo_normal" class="logo_container">
		    <div class="logo_align">
		        <a id="custom_logo" class="logo_wrapper" href="https://respect-mag.com/">
		        			    		<img src="https://respect-mag.com/wp-content/uploads/2018/06/respectlogo.jpg" alt="" width="229" height="50"/>
		    				        </a>
		    </div>
		</div>
				
		    	<div id="logo_transparent" class="logo_container">
    		<div class="logo_align">
	    	    <a id="custom_logo_transparent" class="logo_wrapper" href="https://respect-mag.com/">
	    	    						<img src="https://respect-mag.com/wp-content/uploads/2018/06/respectlogo.jpg" alt="" width="229" height="50"/>
						    	    </a>
    		</div>
    	</div>
    			<!-- End logo -->
		</div>
		
		<div id="menu_wrapper">
	        <div id="nav_wrapper">
	        	<div class="nav_wrapper_inner">
	        		<div id="menu_border_wrapper">
	        			<div class="menu-short-menu-container"><ul id="main_menu" class="nav"><li id="menu-item-189526" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-189526"><a href="https://cover.respect-mag.com/digitalcover/">Digital Cover</a></li>
<li id="menu-item-195484" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-195484"><a href="https://cover.respect-mag.com/print-cover-archive/">Magazine</a></li>
<li id="menu-item-215167" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-215167"><a href="https://cover.respect-mag.com/store">Store</a></li>
</ul></div>	        		</div>
	        	</div>
	        </div>
	        <!-- End main nav -->
        
        <!-- Begin right corner buttons -->
    	<div id="logo_right_button">
	    		    				<a href="javascript:;" id="search_icon">
				<i class="fa fa-search"></i>
				<span class="logo_right_title">Search</span>
			</a>
						<a href="javascript:;" id="mobile_nav_icon">
				<i class="fa fa-bars"></i>
				<span class="logo_right_title">Menu</span>
			</a>
			
    	</div>
    	<!-- End right corner buttons -->
        </div>
    	</div>
    </div>
</div>

<!-- Begin search content -->
<div id="search_wrapper" class="overlay_background">
	<a id="close_search" href="javascript:;"><i class="fa fa-close"></i></a>
	<div class="overlay_background_wrapper">
		<div class="overlay_background_content">
			<div class="overlay_background_content_inner">
				<h2>Search</h2>
				<form role="search" method="get" name="searchform" id="searchform" action="https://respect-mag.com//">
			        <input type="text" value="" name="s" id="s" autocomplete="off" placeholder="Type keywords and hit enter"/>
			        <div id="search_loading_wrapper"><div class="loading_indicator"></div></div>
			        <div id="autocomplete"></div>
			    </form>
			</div>
		</div>
	</div>
</div>
<!-- End search content -->

<!-- Begin browse content -->
<div id="browse_wrapper" class="overlay_background">
	<a id="close_browse" href="javascript:;"><i class="fa fa-close"></i></a>
	<div class="overlay_background_wrapper">
		<div class="overlay_background_content">
			<div class="overlay_background_content_inner">
				<div id="browse_category">
										<h2>Browse</h2>
					<div class="page_tagline">News collects all the stories you want to read</div>
					<ul class="browse_category_wrapper">
														<li class="one_sixth">
									<a href="https://respect-mag.com/category/events/">
										<img src="https://i1.wp.com/respect-mag.com/wp-content/uploads/2018/06/0I2A7673-1.jpg?resize=150%2C100&#038;ssl=1" alt="Events"/>
										<div class="browse_category_name">
											Events										</div>
									</a>
								</li>
														<li class="one_sixth">
									<a href="https://respect-mag.com/category/interviews/">
										<img src="https://i0.wp.com/respect-mag.com/wp-content/uploads/2018/06/J-Cole-Angie-Martinez-1.jpg?resize=150%2C100&#038;ssl=1" alt="Interviews"/>
										<div class="browse_category_name">
											Interviews										</div>
									</a>
								</li>
														<li class="one_sixth">
									<a href="https://respect-mag.com/category/music/">
										<img src="https://i2.wp.com/respect-mag.com/wp-content/uploads/2018/06/jay-rock-win-1-1.jpg?resize=150%2C100&#038;ssl=1" alt="Music"/>
										<div class="browse_category_name">
											Music										</div>
									</a>
								</li>
														<li class="one_sixth">
									<a href="https://respect-mag.com/category/news-2/">
										<img src="https://i2.wp.com/respect-mag.com/wp-content/uploads/2018/06/101077710_gettyimages-629490050-1.jpg?resize=150%2C100&#038;ssl=1" alt="News"/>
										<div class="browse_category_name">
											News										</div>
									</a>
								</li>
														<li class="one_sixth">
									<a href="https://respect-mag.com/category/style/">
										<img src="https://i0.wp.com/respect-mag.com/wp-content/uploads/2018/06/AP9976_LATPAIR.jpg?resize=150%2C100&#038;ssl=1" alt="Style"/>
										<div class="browse_category_name">
											Style										</div>
									</a>
								</li>
														<li class="one_sixth">
									<a href="https://respect-mag.com/category/videos/">
										<img src="https://i2.wp.com/respect-mag.com/wp-content/uploads/2018/06/drake-gods-plan.jpg?resize=150%2C100&#038;ssl=1" alt="Videos"/>
										<div class="browse_category_name">
											Videos										</div>
									</a>
								</li>
											</ul>
									</div>
										<br class="clear"/><br/>
								<div id="browse_author">
					<h3>Editors</h3>
					<ul class="browse_author_wrapper">
													<li class="one_sixth">
								<a href="https://respect-mag.com/author/brittany-burton/">
									<span class="gravatar"><img alt src="https://secure.gravatar.com/avatar/8086e6bcf46a13f4b95a843047e03913?s=150&#038;d=mm&#038;r=g" class="avatar avatar-150 photo jetpack-lazy-image" height="150" width="150" data-lazy-srcset="https://secure.gravatar.com/avatar/8086e6bcf46a13f4b95a843047e03913?s=300&#038;d=mm&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/8086e6bcf46a13f4b95a843047e03913?s=150&amp;is-pending-load=1#038;d=mm&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/8086e6bcf46a13f4b95a843047e03913?s=150&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/8086e6bcf46a13f4b95a843047e03913?s=300&#038;d=mm&#038;r=g 2x' class='avatar avatar-150 photo' height='150' width='150' /></noscript></span>
									<div class="display_name">Brittany Burton</div>
								</a>
							</li>
													<li class="one_sixth">
								<a href="https://respect-mag.com/author/evie-blanco/">
									<span class="gravatar"><img alt src="https://secure.gravatar.com/avatar/7d31a2e30af85216d51a40089f874f42?s=150&#038;d=mm&#038;r=g" class="avatar avatar-150 photo jetpack-lazy-image" height="150" width="150" data-lazy-srcset="https://secure.gravatar.com/avatar/7d31a2e30af85216d51a40089f874f42?s=300&#038;d=mm&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/7d31a2e30af85216d51a40089f874f42?s=150&amp;is-pending-load=1#038;d=mm&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/7d31a2e30af85216d51a40089f874f42?s=150&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/7d31a2e30af85216d51a40089f874f42?s=300&#038;d=mm&#038;r=g 2x' class='avatar avatar-150 photo' height='150' width='150' /></noscript></span>
									<div class="display_name">Evie</div>
								</a>
							</li>
													<li class="one_sixth">
								<a href="https://respect-mag.com/author/haleema-khan/">
									<span class="gravatar"><img alt src="https://secure.gravatar.com/avatar/dd0e7a493f834970d3a46b162ba71cf6?s=150&#038;d=mm&#038;r=g" class="avatar avatar-150 photo jetpack-lazy-image" height="150" width="150" data-lazy-srcset="https://secure.gravatar.com/avatar/dd0e7a493f834970d3a46b162ba71cf6?s=300&#038;d=mm&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/dd0e7a493f834970d3a46b162ba71cf6?s=150&amp;is-pending-load=1#038;d=mm&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/dd0e7a493f834970d3a46b162ba71cf6?s=150&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/dd0e7a493f834970d3a46b162ba71cf6?s=300&#038;d=mm&#038;r=g 2x' class='avatar avatar-150 photo' height='150' width='150' /></noscript></span>
									<div class="display_name">Haleema Khan</div>
								</a>
							</li>
													<li class="one_sixth">
								<a href="https://respect-mag.com/author/infiniti-ingraham/">
									<span class="gravatar"><img alt src="https://secure.gravatar.com/avatar/0e5c4777c0339c80d099462106648861?s=150&#038;d=mm&#038;r=g" class="avatar avatar-150 photo jetpack-lazy-image" height="150" width="150" data-lazy-srcset="https://secure.gravatar.com/avatar/0e5c4777c0339c80d099462106648861?s=300&#038;d=mm&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/0e5c4777c0339c80d099462106648861?s=150&amp;is-pending-load=1#038;d=mm&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/0e5c4777c0339c80d099462106648861?s=150&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/0e5c4777c0339c80d099462106648861?s=300&#038;d=mm&#038;r=g 2x' class='avatar avatar-150 photo' height='150' width='150' /></noscript></span>
									<div class="display_name">Infiniti Ingraham</div>
								</a>
							</li>
													<li class="one_sixth">
								<a href="https://respect-mag.com/author/jalan-burton/">
									<span class="gravatar"><img alt src="https://secure.gravatar.com/avatar/4dd623adb305c12409e40f95c5ef6101?s=150&#038;d=mm&#038;r=g" class="avatar avatar-150 photo jetpack-lazy-image" height="150" width="150" data-lazy-srcset="https://secure.gravatar.com/avatar/4dd623adb305c12409e40f95c5ef6101?s=300&#038;d=mm&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/4dd623adb305c12409e40f95c5ef6101?s=150&amp;is-pending-load=1#038;d=mm&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/4dd623adb305c12409e40f95c5ef6101?s=150&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/4dd623adb305c12409e40f95c5ef6101?s=300&#038;d=mm&#038;r=g 2x' class='avatar avatar-150 photo' height='150' width='150' /></noscript></span>
									<div class="display_name">Jalan Burton</div>
								</a>
							</li>
													<li class="one_sixth">
								<a href="https://respect-mag.com/author/james-lewis/">
									<span class="gravatar"><img alt src="https://secure.gravatar.com/avatar/3d585493c44ce3979ead37a0a3d687c5?s=150&#038;d=mm&#038;r=g" class="avatar avatar-150 photo jetpack-lazy-image" height="150" width="150" data-lazy-srcset="https://secure.gravatar.com/avatar/3d585493c44ce3979ead37a0a3d687c5?s=300&#038;d=mm&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/3d585493c44ce3979ead37a0a3d687c5?s=150&amp;is-pending-load=1#038;d=mm&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/3d585493c44ce3979ead37a0a3d687c5?s=150&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/3d585493c44ce3979ead37a0a3d687c5?s=300&#038;d=mm&#038;r=g 2x' class='avatar avatar-150 photo' height='150' width='150' /></noscript></span>
									<div class="display_name">James Lewis</div>
								</a>
							</li>
													<li class="one_sixth">
								<a href="https://respect-mag.com/author/jasmine-johnson/">
									<span class="gravatar"><img alt src="https://secure.gravatar.com/avatar/e113e179aefae0acf76e0c10fa03d310?s=150&#038;d=mm&#038;r=g" class="avatar avatar-150 photo jetpack-lazy-image" height="150" width="150" data-lazy-srcset="https://secure.gravatar.com/avatar/e113e179aefae0acf76e0c10fa03d310?s=300&#038;d=mm&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/e113e179aefae0acf76e0c10fa03d310?s=150&amp;is-pending-load=1#038;d=mm&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/e113e179aefae0acf76e0c10fa03d310?s=150&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/e113e179aefae0acf76e0c10fa03d310?s=300&#038;d=mm&#038;r=g 2x' class='avatar avatar-150 photo' height='150' width='150' /></noscript></span>
									<div class="display_name">Jasmine Johnson</div>
								</a>
							</li>
													<li class="one_sixth">
								<a href="https://respect-mag.com/author/malcolmtrapp/">
									<span class="gravatar"><img alt src="https://secure.gravatar.com/avatar/997847f863f82870f26bce12420c8d7f?s=150&#038;d=mm&#038;r=g" class="avatar avatar-150 photo jetpack-lazy-image" height="150" width="150" data-lazy-srcset="https://secure.gravatar.com/avatar/997847f863f82870f26bce12420c8d7f?s=300&#038;d=mm&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/997847f863f82870f26bce12420c8d7f?s=150&amp;is-pending-load=1#038;d=mm&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/997847f863f82870f26bce12420c8d7f?s=150&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/997847f863f82870f26bce12420c8d7f?s=300&#038;d=mm&#038;r=g 2x' class='avatar avatar-150 photo' height='150' width='150' /></noscript></span>
									<div class="display_name">Malcolm Trapp</div>
								</a>
							</li>
													<li class="one_sixth">
								<a href="https://respect-mag.com/author/melvin-taylor/">
									<span class="gravatar"><img alt src="https://secure.gravatar.com/avatar/a1b25c8f95364783e27ddf24ce2b8088?s=150&#038;d=mm&#038;r=g" class="avatar avatar-150 photo jetpack-lazy-image" height="150" width="150" data-lazy-srcset="https://secure.gravatar.com/avatar/a1b25c8f95364783e27ddf24ce2b8088?s=300&#038;d=mm&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/a1b25c8f95364783e27ddf24ce2b8088?s=150&amp;is-pending-load=1#038;d=mm&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/a1b25c8f95364783e27ddf24ce2b8088?s=150&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/a1b25c8f95364783e27ddf24ce2b8088?s=300&#038;d=mm&#038;r=g 2x' class='avatar avatar-150 photo' height='150' width='150' /></noscript></span>
									<div class="display_name">Melvin Taylor II</div>
								</a>
							</li>
													<li class="one_sixth">
								<a href="https://respect-mag.com/author/miguel-crespo/">
									<span class="gravatar"><img alt src="https://secure.gravatar.com/avatar/cc3f12c3531c3bd0d770629ae9a8a1ce?s=150&#038;d=mm&#038;r=g" class="avatar avatar-150 photo jetpack-lazy-image" height="150" width="150" data-lazy-srcset="https://secure.gravatar.com/avatar/cc3f12c3531c3bd0d770629ae9a8a1ce?s=300&#038;d=mm&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/cc3f12c3531c3bd0d770629ae9a8a1ce?s=150&amp;is-pending-load=1#038;d=mm&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/cc3f12c3531c3bd0d770629ae9a8a1ce?s=150&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/cc3f12c3531c3bd0d770629ae9a8a1ce?s=300&#038;d=mm&#038;r=g 2x' class='avatar avatar-150 photo' height='150' width='150' /></noscript></span>
									<div class="display_name">Miguel Crespo</div>
								</a>
							</li>
													<li class="one_sixth">
								<a href="https://respect-mag.com/author/robbie-lee/">
									<span class="gravatar"><img alt src="https://secure.gravatar.com/avatar/e2331b4f617ff52aea2c9ae6ff1dbef4?s=150&#038;d=mm&#038;r=g" class="avatar avatar-150 photo jetpack-lazy-image" height="150" width="150" data-lazy-srcset="https://secure.gravatar.com/avatar/e2331b4f617ff52aea2c9ae6ff1dbef4?s=300&#038;d=mm&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/e2331b4f617ff52aea2c9ae6ff1dbef4?s=150&amp;is-pending-load=1#038;d=mm&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/e2331b4f617ff52aea2c9ae6ff1dbef4?s=150&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/e2331b4f617ff52aea2c9ae6ff1dbef4?s=300&#038;d=mm&#038;r=g 2x' class='avatar avatar-150 photo' height='150' width='150' /></noscript></span>
									<div class="display_name">Robbie Lee</div>
								</a>
							</li>
													<li class="one_sixth">
								<a href="https://respect-mag.com/author/tffany-hamilton/">
									<span class="gravatar"><img alt src="https://secure.gravatar.com/avatar/cc8ccf6b9e9a026fd9bd3ccbb56c5378?s=150&#038;d=mm&#038;r=g" class="avatar avatar-150 photo jetpack-lazy-image" height="150" width="150" data-lazy-srcset="https://secure.gravatar.com/avatar/cc8ccf6b9e9a026fd9bd3ccbb56c5378?s=300&#038;d=mm&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/cc8ccf6b9e9a026fd9bd3ccbb56c5378?s=150&amp;is-pending-load=1#038;d=mm&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/cc8ccf6b9e9a026fd9bd3ccbb56c5378?s=150&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/cc8ccf6b9e9a026fd9bd3ccbb56c5378?s=300&#038;d=mm&#038;r=g 2x' class='avatar avatar-150 photo' height='150' width='150' /></noscript></span>
									<div class="display_name">Tiffany Hamilton</div>
								</a>
							</li>
													<li class="one_sixth">
								<a href="https://respect-mag.com/author/tracy-mitchell/">
									<span class="gravatar"><img alt src="https://secure.gravatar.com/avatar/9d65c2a710cfd525292a08334feaf3d7?s=150&#038;d=mm&#038;r=g" class="avatar avatar-150 photo jetpack-lazy-image" height="150" width="150" data-lazy-srcset="https://secure.gravatar.com/avatar/9d65c2a710cfd525292a08334feaf3d7?s=300&#038;d=mm&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/9d65c2a710cfd525292a08334feaf3d7?s=150&amp;is-pending-load=1#038;d=mm&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/9d65c2a710cfd525292a08334feaf3d7?s=150&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/9d65c2a710cfd525292a08334feaf3d7?s=300&#038;d=mm&#038;r=g 2x' class='avatar avatar-150 photo' height='150' width='150' /></noscript></span>
									<div class="display_name">Tracy Mitchell</div>
								</a>
							</li>
													<li class="one_sixth">
								<a href="https://respect-mag.com/author/venus-rose/">
									<span class="gravatar"><img alt src="https://secure.gravatar.com/avatar/7b37a7c92e19a1d1a5229a0b078cd23e?s=150&#038;d=mm&#038;r=g" class="avatar avatar-150 photo jetpack-lazy-image" height="150" width="150" data-lazy-srcset="https://secure.gravatar.com/avatar/7b37a7c92e19a1d1a5229a0b078cd23e?s=300&#038;d=mm&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/7b37a7c92e19a1d1a5229a0b078cd23e?s=150&amp;is-pending-load=1#038;d=mm&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/7b37a7c92e19a1d1a5229a0b078cd23e?s=150&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/7b37a7c92e19a1d1a5229a0b078cd23e?s=300&#038;d=mm&#038;r=g 2x' class='avatar avatar-150 photo' height='150' width='150' /></noscript></span>
									<div class="display_name">Venus Rose</div>
								</a>
							</li>
											</ul>
				</div>
							</div>
		</div>
	</div>
</div>
<!-- End browse content --><div id="page_caption" class="hasbg parallax   " style="background-image:url(https://respect-mag.com/wp-content/uploads/2020/03/F96C5E99-E0EE-4309-847B-D2B0A735ED4A.jpeg);" >

			<div class="background_overlay"></div>
		
	<div class="page_title_wrapper">
		
					<div class="standard_wrapper">
				
	    <div class="page_title_inner">
		    <div class="post_icon_wrapper"><div class="post_icon_trend"><i class="fa fa-flash"></i></div></div>			<div class="post_info_cat">
			    			        <a href="https://respect-mag.com/category/music/">Music</a>
			    			</div>
							    	<h1 >Get Familiar With The Haitian Sensation, Mig Arogan</h1>
	    	<div class="post_detail post_date">
			  <span class="post_info_date">
			  	<span>
			  		<i class="fa fa-clock-o"></i>
			  		Posted On March 12, 2020			  	</span>
			  </span>
			  <span class="post_info_author">
			  				  	<a href="https://respect-mag.com/author/omari-white/"><span class="gravatar"><img alt src="https://secure.gravatar.com/avatar/c4e12307790d9e7191af7b79d84679ef?s=60&#038;d=mm&#038;r=g" class="avatar avatar-60 photo jetpack-lazy-image" height="60" width="60" data-lazy-srcset="https://secure.gravatar.com/avatar/c4e12307790d9e7191af7b79d84679ef?s=120&#038;d=mm&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/c4e12307790d9e7191af7b79d84679ef?s=60&amp;is-pending-load=1#038;d=mm&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/c4e12307790d9e7191af7b79d84679ef?s=60&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/c4e12307790d9e7191af7b79d84679ef?s=120&#038;d=mm&#038;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></noscript></span>Omari White</a>
			  </span>
			  <span class="post_info_comment">
			  	<i class="fa fa-comment-o"></i>0			  </span>
			</div>
	    </div>
	    
	    			</div>
			</div>
	<br class="clear"/>
</div>

<!-- Begin content -->
<div id="page_content_wrapper" class="hasbg ">
<div class="inner">

	<!-- Begin main content -->
	<div class="inner_wrapper">

		<div class="sidebar_content">
					
						
<!-- Begin each blog post -->
<div id="post-238493" class="post-238493 post type-post status-publish format-standard has-post-thumbnail hentry category-music tag-mig-arogan">

	<div class="post_wrapper">
	    
	    <div class="post_content_wrapper">
	    
	    		
	    	    <div class="post_img featured_content">
	    	    	<a href="https://respect-mag.com/wp-content/uploads/2020/03/F96C5E99-E0EE-4309-847B-D2B0A735ED4A.jpeg" class="img_frame">
	    	    		<img src="https://i2.wp.com/respect-mag.com/wp-content/uploads/2020/03/F96C5E99-E0EE-4309-847B-D2B0A735ED4A.jpeg?fit=640%2C640&#038;ssl=1" alt="" class="" style="width:640px;height:640px;"/>
	             </a>
	    	    </div>
	
	<aside class="mashsb-container mashsb-main mashsb-stretched"><div class="mashsb-box"><div class="mashsb-buttons"><a  class="mashicon-facebook mash-large mash-center mashsb-noshadow" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Frespect-mag.com%2F2020%2F03%2Fget-familiar-with-the-haitian-sensation-mig-arogan%2F" target="_top" rel="nofollow"><span class="icon"></span><span class="text">Share</span></a><a  class="mashicon-twitter mash-large mash-center mashsb-noshadow" href="https://twitter.com/intent/tweet?text=Get%20Familiar%20With%20The%20Haitian%20Sensation%2C%20Mig%20Arogan&url=https://respect-mag.com/2020/03/get-familiar-with-the-haitian-sensation-mig-arogan/&via=respectmag" target="_top" rel="nofollow"><span class="icon"></span><span class="text">Tweet</span></a><div class="onoffswitch2 mash-large mashsb-noshadow" style="display:none;"></div></div>
            </div>
                <div style="clear:both;"></div><div class="mashsb-toggle-container"></div></aside>
            <!-- Share buttons by mashshare.net - Version: 3.7.2--><p>Haiti is known for becoming an influential movement in politics, pop and hip hop culture. Just look at the roster.<strong> Future</strong>, <strong>Ace Hood</strong> and legendary emcee, <strong>Wyclef Jean</strong>. A Grammy-award winner and platinum emcee, Wyclef was able to put Haiti on the map as he was able to open the door for a generation of new emcees to break ground. It&#8217;s looking like the time has finally arrived.</p>
<p>Meet Mickenly Thoby aka <strong>MiG Arogan. </strong>This Brooklyn bred lyricist who is of Haitian descent that understands that swagger and lyrical presence is the recipe of success in the hip hop game. Only 25 years old, he has dropped a banger to go along with the visual for the hit song “Blazed Up”. Produced by <strong>LouLou Beatz,</strong> the visual is rumored to be one of the most expensive videos ever produced by a Haitian born artist. It was shot in Canada and in Miami, MiG and featuring Canadian artist <strong>Sliow Capone</strong>, &#8220;Blazed Up&#8221; can be compared to a mini-movie — as it displayed flashes of the lifestyle of the rich and famous. It even included a private jet that carries a $4 million price tag. Now, can you buy that? At $25K a day, it’s even a big-ticket to rent.</p>
<p>Check out the visual right here and be sure to put this dope emcee on your radar.</p>
<p>&nbsp;</p>
<p><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' type='text/html' width='640' height='360' src='https://www.youtube.com/embed/b67eUxcIfQ8?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span></p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-238493" class="share-twitter sd-button share-icon no-text" href="https://respect-mag.com/2020/03/get-familiar-with-the-haitian-sensation-mig-arogan/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-238493" class="share-facebook sd-button share-icon no-text" href="https://respect-mag.com/2020/03/get-familiar-with-the-haitian-sensation-mig-arogan/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div><div id="pp_ads_single_after_content" class="ads_wrapper"><div class="bigad1"><a href="https://www.dragopublisher.com/product/this-is-los-angeles/" rel="noopener" target="_blank"><img src="https://respect-mag.com/wp-content/uploads/2019/07/728x90.gif" alt="" width="728" height="90" class="aligncenter size-full wp-image-221862" /></a></div>
<div class="smallad"><a href="https://www.dragopublisher.com/product/this-is-los-angeles/" rel="noopener" target="_blank"><img src="https://respect-mag.com/wp-content/uploads/2019/07/320x50_EO.gif" alt="" width="320" height="50" class="aligncenter size-full wp-image-221862" /></a></div></div>    <div class="post_excerpt post_tag">
    	<a href="https://respect-mag.com/tag/mig-arogan/">#Mig Arogan</a>    </div>

<div id="post_share_text" class="post_share_text"><i class="fa fa-share-alt"></i></div>			
			<br class="clear"/>
			

  	<h5>More from Music</h5><hr/>
  	<div class="post_more">
    	<!-- Begin each blog post -->
	<div id="post-238547" class="post-238547 post type-post status-publish format-standard has-post-thumbnail hentry category-new-music-2 tag-panda-badazz tag-rappa">
	
		<div class="post_wrapper">
		    
		    <div class="post_content_wrapper">
		    
		    	<div class="post_header search">
			    						
					    <div class="post_img static one_third">
					      	<a href="https://respect-mag.com/2020/03/ontheradar-rappa-panda-big-safe/">
					      		<img src="https://i1.wp.com/respect-mag.com/wp-content/uploads/2020/03/5E27402D-D47C-4BDB-BD7D-CB4FA2CC2397.jpeg?resize=600%2C388&#038;ssl=1" alt="" class="" style="width:600px;height:388px;"/>
					      		
					      		<div class="post_icon_wrapper"><div class="post_icon_trend"><i class="fa fa-flash"></i></div></div>											<div class="post_img_type_wrapper">
									    		<i class="fa fa-video-camera"></i>
									    	</div>
														      	
						      							      	
						     </a>
					     </div>
					
										
					<div class="post_header_title two_third last">
				      	<h5><a href="https://respect-mag.com/2020/03/ontheradar-rappa-panda-big-safe/" title="#PeepTheVisual- Rappa x Panda BadAzz- “Big Safes” (Official Music Video)">#PeepTheVisual- Rappa x Panda BadAzz- “Big Safes” (Official Music Video)</a></h5>
				      	<div class="post_detail post_date">
				      		<span class="post_info_date">
				      			<span>
				      				<a href="https://respect-mag.com/2020/03/ontheradar-rappa-panda-big-safe/">
					      				<i class="fa fa-clock-o"></i>
					       				Posted On March 12, 2020				      				</a>
				      			</span>
				      		</span>
				      		<span class="post_info_author">
				      							      			<a href="https://respect-mag.com/author/malcolm-worsham/"><span class="gravatar"><img alt src="https://secure.gravatar.com/avatar/877a2be5eb7733d88238c8d3ad19a8f8?s=60&#038;d=mm&#038;r=g" class="avatar avatar-60 photo jetpack-lazy-image" height="60" width="60" data-lazy-srcset="https://secure.gravatar.com/avatar/877a2be5eb7733d88238c8d3ad19a8f8?s=120&#038;d=mm&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/877a2be5eb7733d88238c8d3ad19a8f8?s=60&amp;is-pending-load=1#038;d=mm&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/877a2be5eb7733d88238c8d3ad19a8f8?s=60&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/877a2be5eb7733d88238c8d3ad19a8f8?s=120&#038;d=mm&#038;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></noscript></span>Malcolm Worsham</a>
				      		</span>
				      		<span class="post_info_comment">
						  		<i class="fa fa-comment-o"></i>0						  	</span>
					  	</div>
					  	<p>Watts South Central producer Rappa delivers for the West with his latest visual “Big Safe” in collaboration efforts with Panda …</p>				   </div>
				</div>
				
		    </div>
		    
		</div>
	
	</div>
	<!-- End each blog post -->
    	<!-- Begin each blog post -->
	<div id="post-238507" class="post-238507 post type-post status-publish format-standard has-post-thumbnail hentry category-new-music-2 tag-b-free tag-t-rich">
	
		<div class="post_wrapper">
		    
		    <div class="post_content_wrapper">
		    
		    	<div class="post_header search">
			    						
					    <div class="post_img static one_third">
					      	<a href="https://respect-mag.com/2020/03/ontheradar-t-rich-i-want-you-ft-b-free/">
					      		<img src="https://i0.wp.com/respect-mag.com/wp-content/uploads/2020/03/D5709CF1-9AC0-4B37-874A-1ED5520FD894.jpeg?resize=600%2C454&#038;ssl=1" alt="" class="" style="width:600px;height:454px;"/>
					      		
					      		<div class="post_icon_wrapper"><div class="post_icon_trend"><i class="fa fa-flash"></i></div></div>						      	
						      							      	
						     </a>
					     </div>
					
										
					<div class="post_header_title two_third last">
				      	<h5><a href="https://respect-mag.com/2020/03/ontheradar-t-rich-i-want-you-ft-b-free/" title="#OnTheRadar- T Rich- “I Want Youu” Ft. B Free">#OnTheRadar- T Rich- “I Want Youu” Ft. B Free</a></h5>
				      	<div class="post_detail post_date">
				      		<span class="post_info_date">
				      			<span>
				      				<a href="https://respect-mag.com/2020/03/ontheradar-t-rich-i-want-you-ft-b-free/">
					      				<i class="fa fa-clock-o"></i>
					       				Posted On March 12, 2020				      				</a>
				      			</span>
				      		</span>
				      		<span class="post_info_author">
				      							      			<a href="https://respect-mag.com/author/malcolm-worsham/"><span class="gravatar"><img alt src="https://secure.gravatar.com/avatar/877a2be5eb7733d88238c8d3ad19a8f8?s=60&#038;d=mm&#038;r=g" class="avatar avatar-60 photo jetpack-lazy-image" height="60" width="60" data-lazy-srcset="https://secure.gravatar.com/avatar/877a2be5eb7733d88238c8d3ad19a8f8?s=120&#038;d=mm&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/877a2be5eb7733d88238c8d3ad19a8f8?s=60&amp;is-pending-load=1#038;d=mm&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/877a2be5eb7733d88238c8d3ad19a8f8?s=60&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/877a2be5eb7733d88238c8d3ad19a8f8?s=120&#038;d=mm&#038;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></noscript></span>Malcolm Worsham</a>
				      		</span>
				      		<span class="post_info_comment">
						  		<i class="fa fa-comment-o"></i>0						  	</span>
					  	</div>
					  	<p>Detroit artist T. RICH is a super talented, triple threat from Detroit. You may ask what the threats are; but let’s …</p>				   </div>
				</div>
				
		    </div>
		    
		</div>
	
	</div>
	<!-- End each blog post -->
    	<!-- Begin each blog post -->
	<div id="post-238488" class="post-238488 post type-post status-publish format-standard has-post-thumbnail hentry category-music category-new-music-2 tag-bray tag-gorgy">
	
		<div class="post_wrapper">
		    
		    <div class="post_content_wrapper">
		    
		    	<div class="post_header search">
			    						
					    <div class="post_img static one_third">
					      	<a href="https://respect-mag.com/2020/03/ontheradar-falling-for-me-bray-feat-gorgy/">
					      		<img src="https://i2.wp.com/respect-mag.com/wp-content/uploads/2020/03/IMG_1449.jpg?resize=600%2C454&#038;ssl=1" alt="" class="" style="width:600px;height:454px;"/>
					      		
					      		<div class="post_icon_wrapper"><div class="post_icon_trend"><i class="fa fa-flash"></i></div></div>						      	
						      							      	
						     </a>
					     </div>
					
										
					<div class="post_header_title two_third last">
				      	<h5><a href="https://respect-mag.com/2020/03/ontheradar-falling-for-me-bray-feat-gorgy/" title="#OnTheRadar: &#8220;Falling For Me&#8221;- Bray feat Gorgy">#OnTheRadar: &#8220;Falling For Me&#8221;- Bray feat Gorgy</a></h5>
				      	<div class="post_detail post_date">
				      		<span class="post_info_date">
				      			<span>
				      				<a href="https://respect-mag.com/2020/03/ontheradar-falling-for-me-bray-feat-gorgy/">
					      				<i class="fa fa-clock-o"></i>
					       				Posted On March 12, 2020				      				</a>
				      			</span>
				      		</span>
				      		<span class="post_info_author">
				      							      			<a href="https://respect-mag.com/author/omari-white/"><span class="gravatar"><img alt src="https://secure.gravatar.com/avatar/c4e12307790d9e7191af7b79d84679ef?s=60&#038;d=mm&#038;r=g" class="avatar avatar-60 photo jetpack-lazy-image" height="60" width="60" data-lazy-srcset="https://secure.gravatar.com/avatar/c4e12307790d9e7191af7b79d84679ef?s=120&#038;d=mm&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/c4e12307790d9e7191af7b79d84679ef?s=60&amp;is-pending-load=1#038;d=mm&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/c4e12307790d9e7191af7b79d84679ef?s=60&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/c4e12307790d9e7191af7b79d84679ef?s=120&#038;d=mm&#038;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></noscript></span>Omari White</a>
				      		</span>
				      		<span class="post_info_comment">
						  		<i class="fa fa-comment-o"></i>0						  	</span>
					  	</div>
					  	<p>Chattanooga's own Bray is back with another banger as he is ready to show everyone he is here to stay. The …</p>				   </div>
				</div>
				
		    </div>
		    
		</div>
	
	</div>
	<!-- End each blog post -->
      	</div>
  	<h5>Editor Picks</h5><hr/>
  	<div class="post_editor">
    	<div id="post-238043" class="one_half post-238043 post type-post status-publish format-standard has-post-thumbnail hentry category-features category-music category-new-music-2 tag-35033 tag-batmanonthebeatz tag-bryson-tiller tag-decisions tag-future-rb tag-lyfe-harris tag-roy-woods tag-sledgren tag-taylor-gang tag-tyus tag-utu">
		<div class="post_wrapper">
		    <div class="post_content_wrapper">
			    <div class="two_third post_header">
				    <h5><a href="https://respect-mag.com/2020/03/lyfe-harris-brings-booming-sultry-vibes-with-decisions-music-video/" title="Lyfe Harris Brings Booming Sultry Vibes With &#8216;Decisions&#8217; Music Video">Lyfe Harris Brings Booming Sultry Vibes With &#8216;Decisions&#8217; Music Video</a></h5>
				    <div class="post_detail post_date">
				      <span class="post_info_date">
				      	<span>
				      		<a href="https://respect-mag.com/2020/03/lyfe-harris-brings-booming-sultry-vibes-with-decisions-music-video/">
					      		<i class="fa fa-clock-o"></i>
					      		March 11, 2020				      		</a>
				      	</span>
				      </span>
				      <span class="post_info_comment">
						  <i class="fa fa-comment-o"></i>0					  </span>
					</div>
			    </div>
			    
			    <div class="one_third last">
				    					<div class="post_img thumbnail">
					 	<a href="https://respect-mag.com/2020/03/lyfe-harris-brings-booming-sultry-vibes-with-decisions-music-video/">
					 		<img src="https://i1.wp.com/respect-mag.com/wp-content/uploads/2020/03/84477948_2591092947779573_6180772059144569480_n.jpg?resize=150%2C100&#038;ssl=1" alt="" class="" style="width:150px;height:100px;"/>
					 		
					 		<div class="post_icon_wrapper"></div>					    </a>
					</div>
								    </div>
		    </div>
		</div>
	</div>
    	<div id="post-237828" class="one_half last post-237828 post type-post status-publish format-standard has-post-thumbnail hentry category-features category-header-featured category-interviews category-music category-new-music-2 tag-ashanti tag-bow-wow tag-can-you-hear-me tag-electro-hop tag-hip-house tag-jaden-smith tag-omarion tag-passport tag-t-pain tag-the-millenium-tour-2020 tag-unbothered">
		<div class="post_wrapper">
		    <div class="post_content_wrapper">
			    <div class="two_third post_header">
				    <h5><a href="https://respect-mag.com/2020/03/respect-interview-omarion-talks-millennium-tour-2020-jaden-smith-collab-being-a-king/" title="RESPECT. Interview: Omarion Talks Millennium Tour 2020, Jaden Smith Collab &#038; Being a King">RESPECT. Interview: Omarion Talks Millennium Tour 2020, Jaden Smith Collab &#038; Being a King</a></h5>
				    <div class="post_detail post_date">
				      <span class="post_info_date">
				      	<span>
				      		<a href="https://respect-mag.com/2020/03/respect-interview-omarion-talks-millennium-tour-2020-jaden-smith-collab-being-a-king/">
					      		<i class="fa fa-clock-o"></i>
					      		March 10, 2020				      		</a>
				      	</span>
				      </span>
				      <span class="post_info_comment">
						  <i class="fa fa-comment-o"></i>0					  </span>
					</div>
			    </div>
			    
			    <div class="one_third last">
				    					<div class="post_img thumbnail">
					 	<a href="https://respect-mag.com/2020/03/respect-interview-omarion-talks-millennium-tour-2020-jaden-smith-collab-being-a-king/">
					 		<img src="https://i1.wp.com/respect-mag.com/wp-content/uploads/2020/03/70421868_2625027290898326_1916644131278971111_n.jpg?resize=150%2C100&#038;ssl=1" alt="" class="" style="width:150px;height:100px;"/>
					 		
					 		<div class="post_icon_wrapper"></div>					    </a>
					</div>
								    </div>
		    </div>
		</div>
	</div>
    	<div id="post-238237" class="one_half post-238237 post type-post status-publish format-standard has-post-thumbnail hentry category-features category-lifestyle tag-cheko-marsical">
		<div class="post_wrapper">
		    <div class="post_content_wrapper">
			    <div class="two_third post_header">
				    <h5><a href="https://respect-mag.com/2020/03/cheko-mariscal-the-car-influencer-you-must-follow-today/" title="Cheko Mariscal—The Car Influencer You Must Follow Today">Cheko Mariscal—The Car Influencer You Must Follow Today</a></h5>
				    <div class="post_detail post_date">
				      <span class="post_info_date">
				      	<span>
				      		<a href="https://respect-mag.com/2020/03/cheko-mariscal-the-car-influencer-you-must-follow-today/">
					      		<i class="fa fa-clock-o"></i>
					      		March 10, 2020				      		</a>
				      	</span>
				      </span>
				      <span class="post_info_comment">
						  <i class="fa fa-comment-o"></i>0					  </span>
					</div>
			    </div>
			    
			    <div class="one_third last">
				    					<div class="post_img thumbnail">
					 	<a href="https://respect-mag.com/2020/03/cheko-mariscal-the-car-influencer-you-must-follow-today/">
					 		<img src="https://i1.wp.com/respect-mag.com/wp-content/uploads/2020/03/CE979BFC-0078-4B0F-B01B-DD05E59ECC10.jpeg?resize=150%2C100&#038;ssl=1" alt="" class="" style="width:150px;height:100px;"/>
					 		
					 		<div class="post_icon_wrapper"></div>					    </a>
					</div>
								    </div>
		    </div>
		</div>
	</div>
    	<div id="post-237697" class="one_half last post-237697 post type-post status-publish format-standard has-post-thumbnail hentry category-fashion-2 category-features tag-rachel-choy">
		<div class="post_wrapper">
		    <div class="post_content_wrapper">
			    <div class="two_third post_header">
				    <h5><a href="https://respect-mag.com/2020/03/hire-a-personal-shopper-to-wear-your-worth-rachel-choy/" title="Hire a Personal Shopper to Wear Your Worth: Rachel Choy">Hire a Personal Shopper to Wear Your Worth: Rachel Choy</a></h5>
				    <div class="post_detail post_date">
				      <span class="post_info_date">
				      	<span>
				      		<a href="https://respect-mag.com/2020/03/hire-a-personal-shopper-to-wear-your-worth-rachel-choy/">
					      		<i class="fa fa-clock-o"></i>
					      		March 3, 2020				      		</a>
				      	</span>
				      </span>
				      <span class="post_info_comment">
						  <i class="fa fa-comment-o"></i>0					  </span>
					</div>
			    </div>
			    
			    <div class="one_third last">
				    					<div class="post_img thumbnail">
					 	<a href="https://respect-mag.com/2020/03/hire-a-personal-shopper-to-wear-your-worth-rachel-choy/">
					 		<img src="https://i0.wp.com/respect-mag.com/wp-content/uploads/2020/03/6FC78758-F6AF-44B5-A840-4AE497482F75.jpeg?resize=150%2C100&#038;ssl=1" alt="" class="" style="width:150px;height:100px;"/>
					 		
					 		<div class="post_icon_wrapper"></div>					    </a>
					</div>
								    </div>
		    </div>
		</div>
	</div>
      	</div>
			
	    </div>
	    
	</div>

</div>
<!-- End each blog post -->

<div class="fullwidth_comment_wrapper sidebar">
	 




 

	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2020/03/get-familiar-with-the-haitian-sensation-mig-arogan/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://respect-mag.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea placeholder="Comments*" id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input placeholder="Name*" id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input type="email" placeholder="Email*"  id="email" name="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input placeholder="Website" id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='238493' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="7ccd96a590" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="230"/></p></form>	</div><!-- #respond -->
	<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p>			
</div>

						
    	</div>

    		<div class="sidebar_wrapper">
    		
    			<div class="sidebar_top"></div>
    		
    			<div class="sidebar">
    			
    				<div class="content">

    							    	    		<ul class="sidebar_widget">
		    	    		<li id="text-34" class="widget widget_text"><h2 class="widgettitle">Latest Cover</h2>
			<div class="textwidget"><p><a href="https://cover.respect-mag.com/tay-keith/"><img src="https://i1.wp.com/respect-mag.com/wp-content/uploads/2019/08/cover.png?ssl=1" data-recalc-dims="1" data-lazy-src="https://i1.wp.com/respect-mag.com/wp-content/uploads/2019/08/cover.png?ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img src="https://i1.wp.com/respect-mag.com/wp-content/uploads/2019/08/cover.png?ssl=1" data-recalc-dims="1" /></noscript></a></p>
</div>
		</li>
<li id="grand_magazine_custom_ads-3" class="widget Grand_Magazine_Custom_Ads"><a href="https://www.dragopublisher.com/product/this-is-los-angeles/" rel="noopener" target="_blank"><img src="https://respect-mag.com/wp-content/uploads/2019/07/300600.gif" alt="" width="300" height="600" class="aligncenter size-full wp-image-221862" /></a></li>
<li id="text-35" class="widget widget_text"><h2 class="widgettitle">RESPECT. Feature: DaBaby</h2>
			<div class="textwidget"><p><a href="https://respect-mag.com/2019/07/respect-feature-dababy/"><img src="https://i0.wp.com/respect-mag.com/wp-content/uploads/2019/07/IMG_1291.jpg" data-lazy-src="https://i0.wp.com/respect-mag.com/wp-content/uploads/2019/07/IMG_1291.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img src="https://i0.wp.com/respect-mag.com/wp-content/uploads/2019/07/IMG_1291.jpg" /></noscript></a></p>
</div>
		</li>
<li id="top-posts-2" class="widget widget_top-posts"><h2 class="widgettitle">Top Posts</h2>
<ul>				<li>
					<a href="https://respect-mag.com/2020/03/rapper-sqoottm-moves-like-a-boss-and-a-general-in-new-sexy-video/" class="bump-view" data-bump-view="tp">Rapper SQootTM Moves Like A Boss And A General In New “Sexy” Video</a>					</li>
								<li>
					<a href="https://respect-mag.com/2020/03/respect-interview-omarion-talks-millennium-tour-2020-jaden-smith-collab-being-a-king/" class="bump-view" data-bump-view="tp">RESPECT. Interview: Omarion Talks Millennium Tour 2020, Jaden Smith Collab &amp; Being a King</a>					</li>
								<li>
					<a href="https://respect-mag.com/2020/03/vans-releases-sensory-inclusive-designs-to-support-autism-awareness-through-creativity/" class="bump-view" data-bump-view="tp">Vans Releases Sensory Inclusive Designs to Support Autism Awareness Through Creativity</a>					</li>
								<li>
					<a href="https://respect-mag.com/2020/03/medcare-cannabis-and-dj-carisma-celebrate-a-huge-grand-opening-in-southern-california/" class="bump-view" data-bump-view="tp">MedCare Cannabis and DJ Carisma Celebrate a Huge Grand Opening in Southern California</a>					</li>
								<li>
					<a href="https://respect-mag.com/2020/03/respect-interview-josh-stone-talks-suing-ariana-grande-over-hit-song-7-rings/" class="bump-view" data-bump-view="tp">RESPECT. Interview: Josh Stone Talks Suing Ariana Grande Over Hit Song &quot;7 Rings&quot;</a>					</li>
				</ul></li>
<li id="grand_magazine_custom_ads-9" class="widget Grand_Magazine_Custom_Ads"><a href="https://www.dragopublisher.com/product/this-is-los-angeles/" rel="noopener" target="_blank"><img src="https://respect-mag.com/wp-content/uploads/2019/07/350x250.gif" alt="" width="300" height="600" class="aligncenter size-full wp-image-221862" /></a></li>
		    	    		</ul>
		    	    	    				
    				</div>
    		
    			</div>
    			<br class="clear"/>
    	
    			<div class="sidebar_bottom"></div>
    		</div>
    
    </div>
    <!-- End main content -->
   
</div>

<br class="clear"/>

</div>



<br class="clear"/>
<div class="footer_bar   ">
	
		
		<div id="footer_browse_category" class="standard_wrapper">
		<h2>Browse</h2>
		<div class="page_tagline">Browse RESPECT. by category</div>
		<ul class="browse_category_wrapper">
								<li class="one_sixth">
						<a href="https://respect-mag.com/category/events/">
							<img src="https://i1.wp.com/respect-mag.com/wp-content/uploads/2018/06/0I2A7673-1.jpg?resize=150%2C100&#038;ssl=1" alt="Events"/>
							<div class="browse_category_name">
								Events							</div>
						</a>
					</li>
								<li class="one_sixth">
						<a href="https://respect-mag.com/category/interviews/">
							<img src="https://i0.wp.com/respect-mag.com/wp-content/uploads/2018/06/J-Cole-Angie-Martinez-1.jpg?resize=150%2C100&#038;ssl=1" alt="Interviews"/>
							<div class="browse_category_name">
								Interviews							</div>
						</a>
					</li>
								<li class="one_sixth">
						<a href="https://respect-mag.com/category/music/">
							<img src="https://i2.wp.com/respect-mag.com/wp-content/uploads/2018/06/jay-rock-win-1-1.jpg?resize=150%2C100&#038;ssl=1" alt="Music"/>
							<div class="browse_category_name">
								Music							</div>
						</a>
					</li>
								<li class="one_sixth">
						<a href="https://respect-mag.com/category/news-2/">
							<img src="https://i2.wp.com/respect-mag.com/wp-content/uploads/2018/06/101077710_gettyimages-629490050-1.jpg?resize=150%2C100&#038;ssl=1" alt="News"/>
							<div class="browse_category_name">
								News							</div>
						</a>
					</li>
								<li class="one_sixth">
						<a href="https://respect-mag.com/category/style/">
							<img src="https://i0.wp.com/respect-mag.com/wp-content/uploads/2018/06/AP9976_LATPAIR.jpg?resize=150%2C100&#038;ssl=1" alt="Style"/>
							<div class="browse_category_name">
								Style							</div>
						</a>
					</li>
								<li class="one_sixth">
						<a href="https://respect-mag.com/category/videos/">
							<img src="https://i2.wp.com/respect-mag.com/wp-content/uploads/2018/06/drake-gods-plan.jpg?resize=150%2C100&#038;ssl=1" alt="Videos"/>
							<div class="browse_category_name">
								Videos							</div>
						</a>
					</li>
					</ul>
		<br class="clear"/>
	</div>
	
		<div id="footer" class="">
	<ul class="sidebar_widget two">
	    <li id="text-36" class="widget widget_text">			<div class="textwidget"><p><a href="https://www.respect-mag.com"><img src="https://i0.wp.com/respect-mag.com/wp-content/uploads/2018/06/respectlogo.jpg?ssl=1" data-recalc-dims="1" data-lazy-src="https://i0.wp.com/respect-mag.com/wp-content/uploads/2018/06/respectlogo.jpg?ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img src="https://i0.wp.com/respect-mag.com/wp-content/uploads/2018/06/respectlogo.jpg?ssl=1" data-recalc-dims="1"/></noscript></a></p>
<p>The hip-hop nation demands respect.  </p>
<p>RESPECT. Magazine targets a sophisticated and intelligent reader, who desires a publication that speaks to them with class and visually has soul.</p>
<p>Welcome to the new old school.</p>
</div>
		</li>
<li id="tag_cloud-2" class="widget widget_tag_cloud"><h2 class="widgettitle">Tags</h2>
<div class="tagcloud"><a href="https://respect-mag.com/tag/2-chainz/" class="tag-cloud-link tag-link-3314 tag-link-position-1" style="font-size: 13px;">2 Chainz</a>
<a href="https://respect-mag.com/tag/50-cent/" class="tag-cloud-link tag-link-127 tag-link-position-2" style="font-size: 13px;">50 Cent</a>
<a href="https://respect-mag.com/tag/aap-rocky/" class="tag-cloud-link tag-link-3453 tag-link-position-3" style="font-size: 13px;">A$AP Rocky</a>
<a href="https://respect-mag.com/tag/action-bronson/" class="tag-cloud-link tag-link-3173 tag-link-position-4" style="font-size: 13px;">Action Bronson</a>
<a href="https://respect-mag.com/tag/beyonce/" class="tag-cloud-link tag-link-1394 tag-link-position-5" style="font-size: 13px;">Beyonce</a>
<a href="https://respect-mag.com/tag/big-sean/" class="tag-cloud-link tag-link-1122 tag-link-position-6" style="font-size: 13px;">big sean</a>
<a href="https://respect-mag.com/tag/brooklyn/" class="tag-cloud-link tag-link-660 tag-link-position-7" style="font-size: 13px;">brooklyn</a>
<a href="https://respect-mag.com/tag/chance-the-rapper/" class="tag-cloud-link tag-link-6773 tag-link-position-8" style="font-size: 13px;">Chance the Rapper</a>
<a href="https://respect-mag.com/tag/chicago/" class="tag-cloud-link tag-link-286 tag-link-position-9" style="font-size: 13px;">Chicago</a>
<a href="https://respect-mag.com/tag/chris-brown/" class="tag-cloud-link tag-link-1148 tag-link-position-10" style="font-size: 13px;">Chris Brown</a>
<a href="https://respect-mag.com/tag/danny-brown/" class="tag-cloud-link tag-link-2835 tag-link-position-11" style="font-size: 13px;">Danny Brown</a>
<a href="https://respect-mag.com/tag/drake/" class="tag-cloud-link tag-link-48 tag-link-position-12" style="font-size: 13px;">Drake</a>
<a href="https://respect-mag.com/tag/eminem/" class="tag-cloud-link tag-link-68 tag-link-position-13" style="font-size: 13px;">Eminem</a>
<a href="https://respect-mag.com/tag/french-montana/" class="tag-cloud-link tag-link-3989 tag-link-position-14" style="font-size: 13px;">french montana</a>
<a href="https://respect-mag.com/tag/future/" class="tag-cloud-link tag-link-3780 tag-link-position-15" style="font-size: 13px;">Future</a>
<a href="https://respect-mag.com/tag/gucci-mane/" class="tag-cloud-link tag-link-154 tag-link-position-16" style="font-size: 13px;">Gucci Mane</a>
<a href="https://respect-mag.com/tag/hip-hop/" class="tag-cloud-link tag-link-751 tag-link-position-17" style="font-size: 13px;">hip-hop</a>
<a href="https://respect-mag.com/tag/j-cole/" class="tag-cloud-link tag-link-164 tag-link-position-18" style="font-size: 13px;">J. Cole</a>
<a href="https://respect-mag.com/tag/jay-z/" class="tag-cloud-link tag-link-19 tag-link-position-19" style="font-size: 13px;">Jay-Z</a>
<a href="https://respect-mag.com/tag/joey-bada/" class="tag-cloud-link tag-link-5480 tag-link-position-20" style="font-size: 13px;">Joey BadA$$</a>
<a href="https://respect-mag.com/tag/kanye-west/" class="tag-cloud-link tag-link-13 tag-link-position-21" style="font-size: 13px;">Kanye West</a>
<a href="https://respect-mag.com/tag/kendrick-lamar/" class="tag-cloud-link tag-link-1041 tag-link-position-22" style="font-size: 13px;">Kendrick Lamar</a>
<a href="https://respect-mag.com/tag/lil-wayne/" class="tag-cloud-link tag-link-64 tag-link-position-23" style="font-size: 13px;">Lil&#039; Wayne</a>
<a href="https://respect-mag.com/tag/mac-miller/" class="tag-cloud-link tag-link-881 tag-link-position-24" style="font-size: 13px;">Mac Miller</a>
<a href="https://respect-mag.com/tag/meek-mill/" class="tag-cloud-link tag-link-1079 tag-link-position-25" style="font-size: 13px;">meek mill</a>
<a href="https://respect-mag.com/tag/mixtape/" class="tag-cloud-link tag-link-1696 tag-link-position-26" style="font-size: 13px;">mixtape</a>
<a href="https://respect-mag.com/tag/mmg/" class="tag-cloud-link tag-link-1185 tag-link-position-27" style="font-size: 13px;">MMG</a>
<a href="https://respect-mag.com/tag/nas/" class="tag-cloud-link tag-link-170 tag-link-position-28" style="font-size: 13px;">Nas</a>
<a href="https://respect-mag.com/tag/nicki-minaj/" class="tag-cloud-link tag-link-184 tag-link-position-29" style="font-size: 13px;">Nicki Minaj</a>
<a href="https://respect-mag.com/tag/odd-future/" class="tag-cloud-link tag-link-761 tag-link-position-30" style="font-size: 13px;">Odd Future</a>
<a href="https://respect-mag.com/tag/pusha-t/" class="tag-cloud-link tag-link-595 tag-link-position-31" style="font-size: 13px;">Pusha T</a>
<a href="https://respect-mag.com/tag/rick-ross/" class="tag-cloud-link tag-link-189 tag-link-position-32" style="font-size: 13px;">Rick Ross</a>
<a href="https://respect-mag.com/tag/rihanna/" class="tag-cloud-link tag-link-71 tag-link-position-33" style="font-size: 13px;">Rihanna</a>
<a href="https://respect-mag.com/tag/schoolboy-q/" class="tag-cloud-link tag-link-2592 tag-link-position-34" style="font-size: 13px;">schoolboy q</a>
<a href="https://respect-mag.com/tag/t-i/" class="tag-cloud-link tag-link-176 tag-link-position-35" style="font-size: 13px;">T.I.</a>
<a href="https://respect-mag.com/tag/tde/" class="tag-cloud-link tag-link-3178 tag-link-position-36" style="font-size: 13px;">TDE</a>
<a href="https://respect-mag.com/tag/the-weeknd/" class="tag-cloud-link tag-link-1113 tag-link-position-37" style="font-size: 13px;">the weeknd</a>
<a href="https://respect-mag.com/tag/toronto/" class="tag-cloud-link tag-link-2566 tag-link-position-38" style="font-size: 13px;">Toronto</a>
<a href="https://respect-mag.com/tag/ty-dolla-ign/" class="tag-cloud-link tag-link-10650 tag-link-position-39" style="font-size: 13px;">Ty Dolla $ign</a>
<a href="https://respect-mag.com/tag/tyler-the-creator/" class="tag-cloud-link tag-link-701 tag-link-position-40" style="font-size: 13px;">Tyler the creator</a>
<a href="https://respect-mag.com/tag/video/" class="tag-cloud-link tag-link-22055 tag-link-position-41" style="font-size: 13px;">Video</a>
<a href="https://respect-mag.com/tag/wale/" class="tag-cloud-link tag-link-647 tag-link-position-42" style="font-size: 13px;">Wale</a>
<a href="https://respect-mag.com/tag/wiz-khalifa/" class="tag-cloud-link tag-link-710 tag-link-position-43" style="font-size: 13px;">wiz khalifa</a>
<a href="https://respect-mag.com/tag/young-thug/" class="tag-cloud-link tag-link-12888 tag-link-position-44" style="font-size: 13px;">Young Thug</a>
<a href="https://respect-mag.com/tag/youtube/" class="tag-cloud-link tag-link-3042 tag-link-position-45" style="font-size: 13px;">YouTube</a></div>
</li>
	</ul>
	</div>
	<br class="clear"/>
	
	<div class="footer_bar_wrapper ">
					<div class="social_wrapper">
			    <ul>
			    				    	<li class="facebook"><a target="_blank" href="http://www.facebook.com/respectmag"><i class="fa fa-facebook"></i></a></li>
			    				    				    	<li class="twitter"><a target="_blank" href="http://twitter.com/respectmag"><i class="fa fa-twitter"></i></a></li>
			    				    				    				    	<li class="youtube"><a target="_blank" title="Youtube" href="https://www.youtube.com/RESPECTMagazine"><i class="fa fa-youtube"></i></a></li>
			    				    				    				    				    				    				    				        			        <li class="instagram"><a target="_blank" title="Instagram" href="http://instagram.com/respectthemag"><i class="fa fa-instagram"></i></a></li>
			        			        			    </ul>
			</div>
			    <div id="copyright">RESPECT. © 2019 All Rights Reserved // <a href="http://atthe.pub">atthe.pub</a></div>	    
	    	    	<a id="toTop"><i class="fa fa-angle-up"></i></a>
	    	    
	    	</div>
</div>

</div>


<div id="side_menu_wrapper" class="overlay_background">
	<a id="close_mobile_menu" href="javascript:;"><i class="fa fa-close"></i></a>
		<div id="fullscreen_share_wrapper">
		<div class="fullscreen_share_content">
	<h2>Share</h2>
<div class="page_tagline">Share stories you like to your friends</div>
<div id="social_share_wrapper">
	<ul>
		<li><a class="facebook" title="Share On Facebook" target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https://respect-mag.com/2020/03/get-familiar-with-the-haitian-sensation-mig-arogan/"><i class="fa fa-facebook"></i></a></li>
		<li><a class="twitter" title="Share On Twitter" target="_blank" href="https://twitter.com/intent/tweet?original_referer=https://respect-mag.com/2020/03/get-familiar-with-the-haitian-sensation-mig-arogan/&url=https://respect-mag.com/2020/03/get-familiar-with-the-haitian-sensation-mig-arogan/"><i class="fa fa-twitter"></i></a></li>
		<li><a class="pinterest" title="Share On Pinterest" target="_blank" href="http://www.pinterest.com/pin/create/button/?url=https%3A%2F%2Frespect-mag.com%2F2020%2F03%2Fget-familiar-with-the-haitian-sensation-mig-arogan%2F&media=https%3A%2F%2Frespect-mag.com%2Fwp-content%2Fuploads%2F2020%2F03%2FF96C5E99-E0EE-4309-847B-D2B0A735ED4A.jpeg"><i class="fa fa-pinterest"></i></a></li>
		<li><a class="google" title="Share On Google+" target="_blank" href="https://plus.google.com/share?url=https://respect-mag.com/2020/03/get-familiar-with-the-haitian-sensation-mig-arogan/"><i class="fa fa-google-plus"></i></a></li>
		<li><a class="mail" title="Share by Email" href="mailto:someone@example.com?Subject=Get%20Familiar%20With%20The%20Haitian%20Sensation%2C%20Mig%20Arogan&amp;Body=https%3A%2F%2Frespect-mag.com%2F2020%2F03%2Fget-familiar-with-the-haitian-sensation-mig-arogan%2F"><i class="fa fa-envelope"></i></a></li>
	</ul>
</div>		</div>
	</div>
	</div>



<!--Plugin WP Toolbar Removal 2014.0816.0392 Active - Tag 74be16979710d4c4e7c6647856088456-->

<!--Site Optimized to Speedup Control Panel Minimize Memory Consumption with Disabled Toolbar-->

	<div style="display:none">
	<div class="grofile-hash-map-8086e6bcf46a13f4b95a843047e03913">
	</div>
	<div class="grofile-hash-map-7d31a2e30af85216d51a40089f874f42">
	</div>
	<div class="grofile-hash-map-dd0e7a493f834970d3a46b162ba71cf6">
	</div>
	<div class="grofile-hash-map-0e5c4777c0339c80d099462106648861">
	</div>
	<div class="grofile-hash-map-4dd623adb305c12409e40f95c5ef6101">
	</div>
	<div class="grofile-hash-map-3d585493c44ce3979ead37a0a3d687c5">
	</div>
	<div class="grofile-hash-map-e113e179aefae0acf76e0c10fa03d310">
	</div>
	<div class="grofile-hash-map-997847f863f82870f26bce12420c8d7f">
	</div>
	<div class="grofile-hash-map-a1b25c8f95364783e27ddf24ce2b8088">
	</div>
	<div class="grofile-hash-map-cc3f12c3531c3bd0d770629ae9a8a1ce">
	</div>
	<div class="grofile-hash-map-e2331b4f617ff52aea2c9ae6ff1dbef4">
	</div>
	<div class="grofile-hash-map-cc8ccf6b9e9a026fd9bd3ccbb56c5378">
	</div>
	<div class="grofile-hash-map-9d65c2a710cfd525292a08334feaf3d7">
	</div>
	<div class="grofile-hash-map-7b37a7c92e19a1d1a5229a0b078cd23e">
	</div>
	<div class="grofile-hash-map-c4e12307790d9e7191af7b79d84679ef">
	</div>
	<div class="grofile-hash-map-877a2be5eb7733d88238c8d3ad19a8f8">
	</div>
	<div class="grofile-hash-map-c4e12307790d9e7191af7b79d84679ef">
	</div>
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/respect-mag.com\/2020\/03\/get-familiar-with-the-haitian-sensation-mig-arogan\/":238493};
	</script>
				<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.3/_inc/build/photon/photon.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var qpprFrontData = {"linkData":{"https:\/\/respect-mag.com\/2016\/06\/aap-ferg-self-reflections-harlem-knight\/":[0,0,"http:\/\/respect-mag.com\/fergcover\/"],"https:\/\/respect-mag.com\/2016\/12\/cousin-stizz-bostons-finest\/":[0,0,"http:\/\/respect-mag.com\/stizzcover\/"],"https:\/\/respect-mag.com\/2017\/07\/chaz-french-finds-way\/":[0,0,"http:\/\/respect-mag.com\/chazcover.html"],"https:\/\/respect-mag.com\/gshockvid9\/":[0,0,""],"https:\/\/respect-mag.com\/subscription\/":[0,0,""],"https:\/\/respect-mag.com\/2016\/07\/lil-durk-no-pain-no-gain\/":[0,0,""],"https:\/\/respect-mag.com\/2016\/08\/marc-e-bassy\/":[0,0,""],"https:\/\/respect-mag.com\/2018\/05\/digital-cover-re-introduction-big-k-r-t\/":[0,0,""],"https:\/\/respect-mag.com\/2017\/12\/winter-style-guide\/":[0,0,""],"https:\/\/respect-mag.com\/2018\/05\/digital-cover-nipsey-hussles-victory-lap-has-just-begun\/":[0,0,""],"https:\/\/respect-mag.com\/2018\/06\/nick-cannon\/":[0,0,""],"https:\/\/respect-mag.com\/2018\/05\/watch-angie-martinez-latest-sit-down-with-j-cole\/":[0,0,""],"https:\/\/respect-mag.com\/2018\/06\/nasir-has-finally-arrived-check-out-nas-latest-here\/":[0,0,""],"https:\/\/respect-mag.com\/2018\/07\/breaking-6ix9ine-reportedly-beaten-robbed-in-brooklyn\/":[0,0,""],"https:\/\/respect-mag.com\/2018\/09\/q-da-fool-digital-cover\/":[0,0,""],"https:\/\/respect-mag.com\/2018\/09\/the-greatest-day-in-harlem-the-game-changer\/":[0,0,""],"https:\/\/respect-mag.com\/2018\/11\/contact-high-greatest-day\/":[0,0,""],"https:\/\/respect-mag.com\/2019\/03\/respect-digital-cover-what-cant-tory-lanez-do\/":[0,0,""],"https:\/\/respect-mag.com\/2019\/03\/rakim-nas\/":[0,0,""],"https:\/\/respect-mag.com\/2019\/03\/rich-the-kid-digital-cover\/":[0,0,""],"https:\/\/respect-mag.com\/2019\/05\/a-boogie\/":[0,0,""],"https:\/\/respect-mag.com\/2019\/07\/doja-cat-in-her-own-skin\/":[0,0,""],"https:\/\/respect-mag.com\/2019\/08\/tay-keith-the-platinum-guru\/":[0,0,""],"https:\/\/respect-mag.com\/2019\/11\/l-a-s-finest-estevan-oriol-goes-behind-the-lens\/":[0,0,""]},"siteURL":"https:\/\/respect-mag.com","siteURLq":"https:\/\/respect-mag.com"};
/* ]]> */
</script>
<script type='text/javascript' src='https://respect-mag.com/wp-content/plugins/quick-pagepost-redirect-plugin/js/qppr_frontend_script.min.js'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.3/modules/wpgroho.js'></script>
<script type='text/javascript' src='https://respect-mag.com/wp-content/themes/RESPECT2.0/js/jquery.magnific-popup.js'></script>
<script type='text/javascript' src='https://respect-mag.com/wp-content/themes/RESPECT2.0/js/jquery.easing.js'></script>
<script type='text/javascript' src='https://respect-mag.com/wp-content/themes/RESPECT2.0/js/waypoints.min.js'></script>
<script type='text/javascript' src='https://respect-mag.com/wp-content/themes/RESPECT2.0/js/jquery.masory.js'></script>
<script type='text/javascript' src='https://respect-mag.com/wp-content/themes/RESPECT2.0/js/jquery.tooltipster.min.js'></script>
<script type='text/javascript' src='https://respect-mag.com/wp-content/themes/RESPECT2.0/js/jarallax.js'></script>
<script type='text/javascript' src='https://respect-mag.com/wp-content/themes/RESPECT2.0/js/jquery.sticky-kit.min.js'></script>
<script type='text/javascript' src='https://respect-mag.com/wp-content/themes/RESPECT2.0/js/custom_plugins.js'></script>
<script type='text/javascript' src='https://respect-mag.com/wp-content/themes/RESPECT2.0/js/custom.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.3/_inc/build/lazy-images/js/lazy-images.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/wp-embed.min.js'></script>
<script async="async" type='text/javascript' src='https://respect-mag.com/wp-content/plugins/akismet/_inc/form.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.3/_inc/build/sharedaddy/sharing.min.js'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
</script>
<script type='text/javascript' src='https://stats.wp.com/e-202011.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.3',blog:'56491895',post:'238493',tz:'-4',srv:'respect-mag.com'} ]);
	_stq.push([ 'clickTrackerInit', '56491895', '238493' ]);
</script>
</body>
</html>
